Announcement

Collapse
No announcement yet.

The request failed with HTTP status 400: Bad Request.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The request failed with HTTP status 400: Bad Request.

    You are trying to download the license and get the following error msg:




    Click image for larger version

Name:	WBRM-400Error-1.png
Views:	2
Size:	31.8 KB
ID:	183


    ---------------------------
    WBRM - A WebsitePanel Backup, Restore and Migrate Utility v7.4.64-RC34
    ---------------------------
    GetServices failed: The request failed with HTTP status 400: Bad Request.
    ---------------------------
    OK
    ---------------------------


    If you review the Logs, you will also see the following errors:


    INFO 2016-05-20 13:19:08,344 - ES Server Port: 9002
    INFO 2016-05-20 13:19:08,344 - ES Server IP found: 127.0.0.1
    INFO 2016-05-20 13:19:08,344 -
    INFO 2016-05-20 13:19:08,437 - No license found
    ERROR 2016-05-20 13:19:11,981 - Failed to get paged users
    System.Net.WebException: The request failed with HTTP status 400: Bad Request.
    at System.Web.Services.Protocols.SoapHttpClientProtoc ol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)


    REASON/CAUSE:

    The problem is related to the WSP setup and the WBRM License+setup.

    If you are using the WSP installer, click on the Enterprise Server -->> Settings --> then on the second menu, you have the IP to use for the Enterprise Server.

    The default for a standalone server is 127.0.0.1
    However, you can change that to the public IP or any IP.

    That will work for you fine with WSP.

    Now, the WBRM needs to talk to the Enterprise Server to access it's API calls.

    SOLUTION:

    WBRM Standard, Professional and Enterprise type licenses are all defaulting to 127.0.0.1 and even if you try to type a different value, it will be ignored and the WBRM setup
    will be using the 127.0.0.1

    That's where the Error is showing up.
    The WBRM is trying to access 127.0.0.1, whereas you have set the WSP Enterprise to a different IP and of course they can't see each other.

    You need to either change the IP in WSP to 127.0.0.1 or obtain (or upgrade) your WBRM license to distributed and then you can modify and change the value of the
    WSP Enterprise in the WBRM.


Working...
X